How to turn off linting?


#1

All I want to do is turn off linting! I’ve tried putting /* eslint-disable */ at the top of my js file, but I still get the red “X” in the gutter (parsing error) when using flow-type annotations. I just want it to go away! Any ideas how to turn off linting? I can change the syntax to typescript, but it’s still linting, right? Isn’t there a way to turn it off altogether?


#2

This option is called Enable Hints and Warnings inside Preferences > User Settings.
I admit this option is not perfectly named.


#3

Perfect! Thanks, dude!