How to stop cursor from blinking in Cloud9 Ace editor?


#1

I’m used to the cursor not blinking in my IDE, how can I accomplish this in the Cloud9 Ace editor?


#2

you can set cursor style to wide, in user preferences.


#3

It works, thanks. But the user settings don’t seem to be permanently saved, how can I do that? Made this post about it: User settings don’t survive beyond a single session


#4

I have the same problem, except it’s only happening with the cursor style option

I tried changing @cursorStyle in init script by adding this line:
services.settings.set("project/ace/@cursorStyle", "wide")
And i tried to change the @cursorStyle parameter in “user.settings” file to “wide”.

After every refresh the parameter reverts to back to “slim smooth”. And yes i’m sure i saved the file before refreshing :slight_smile:


#5

@k1p0d that is very strange, could you tell the url of your workspace please?


#6

Workspace URL:
https://ide.c9.io/k1p0d/openu

By the way i also tried switching editor to default theme, and resetting workspace settings.


#7

are there any other cloud9 tabs open when you change the setting? Maybe one of them overwrites changed settings with the old ones.


#8

No.

But i noticed that when opening the preferences tab and then refreshing cloud9 - even without changing any setting - the browser warns me that changes may not be saved if i refresh.
The same happens when opening the user.settings file (even after i hit CTRL+S).
It DOESN’T happen with normal code files.

I don’t know if it’s related to the problem but i thought it was worth mentioning.


#9

Turns out this is a bug in flat themes.
Until it is fixed, You can use the classic theme, or add the following to your init script

services.settings.set("user/ace/@cursorStyle", "wide") 

Thanks for helping to find the issue!


#10

Actually i already tried adding exactly this line to the init script and it doesn’t have any effect, so the only workaround is to change to classic theme.
Anyway thanks for the help!


#11

Actually i already tried adding exactly this line to the init script and it doesn’t have any effect,

Did you add the line with user or project? How to stop cursor from blinking in Cloud9 Ace editor? has project which indeed should not have any effect.


#12

You’re right, i added the line with “project”. I should’ve compared the lines side by side before saying it doesn’t work, sorry about that.


#13

This setting seems to have disappeared in AWS C9, where can I find it there?