How to run web app with http (not https)?


#1

Hi all!

I’m new here and I hope this isn’t a too stupid question, but I tried everything I can think of. Running a PHP app will expose it with https, and I can’t make it available via http. I need the latter because the browser complains that the css and js is mixed content…

[edit] It looks that this is only a problem for the preview browser. If using an external browser it works as expected.

best regards,
Vlad


Preview non SSL
Run node app on http (not https)
Angular driven Node site doesn't work on Cloud9, but DOES locally?
Setting Up Drupal
#2

Yeah if you pop it out into it’s own window, then just remove the “s” from “https” and it’ll load.

Docs on “Running Workspaces” just in case someone finds this in their searches:


Getting 404 on /auth/login of c9users.io
#3

Aha, thanks, so the important thing was that one must pop it out in a separate window!

Otherwise, http:// won’t work because it’s mixed inside a https session. The confusing part is that there is no error message, the preview browser just gets an “about:blank” address line…

/Vlad


#4

Live preview uses iframe to embed the preview page in the IDE, so there are limitations to what events and errors we can observe. To get around the mixed content problem, have you tried using relative paths or changing the paths to https?


#5

Thanks, I guessed that was the cause. No, I can’t change the URLs, they are external and don’t have a https alternative, but having the preview browser “popped-out” works ok. It’s just that it’s a bit confusing when hitting the issue the first time.


#6

I am having the same problem. I “think” I am popping it out into its own window (takes me to my Chrome browser). But, when I delete the “s” from https://, Chrome merely puts it back to https on the refresh.

Any ideas? Thanks

PS - I am using an API (openWeather) which does not allow free accounts to access their server via https. I have no choice than to use an http call. C9’s preview over https is causing me to get a “Mixed Content” error in my web console.


#7

Are you accessing OpenWeather because you’re working on the Free Code Camp project? If you are, you’ll be staging your finished code on Codepen, so this will not be an issue as Codepen also uses http.

I have not tried accessing using Chrome, but Safari allows me to remove the ‘s’ in https to access the non-encrypted URL on Cloud9 for the Free Code Camp project. Have you tried Firefox to see if removing the ‘s’ from the URL allows you to view your web console?