How to install things that need a higher version of `six` in Python

python

#1

I tried to install Tensorflow, but I ran into the issue

Found existing installation: six 1.5.2
Cannot uninstall ‘six’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

When I tried to install with the -ignore-installed six option, that also failed. (It failed to install many of the dependencies.)

I thought that I could use the virtualenvwrapper module to get around this, but it turns out that module also depends on a higher version of six.

How can I install these modules which require an upgraded version of six?