How to install Laravel 5.3 to a workspace?



Has anyone had success on installing Laravel 5.3 in their own workspace?

For everyone’s reference, the server requirements can be found here: Laravel 5.3 Installation Steps

FYI: Laravel 5.3 was released yesterday (August 23, 2016)


Yes, I’ve tried to install Laravel 5.3 the -dev branch, two weeks ago I think.
The fact is that when you try to do that, you got errors, it’s impossible because as you mentioned in the link you provided, Laravel 5.3 has a minimum requirement for PHP to be >= 5.6.4 and c9 is shipped with PHP 5.5.9.
What you have to do then is to upgrade your server/workspace to run PHP>= 5.6.24. I didn’t try for PHP 7 but it will be the same I guess.
When you finish check and be sure to install those extensions too, as Laravel 5.3 need that as mentioned in the link
OpenSSL PHP Extension
PDO PHP Extension
Mbstring PHP Extension
Tokenizer PHP Extension
The probleme I had was that phpmyadmin stopped working and I didn’t really look why because I wanted to upgrade it anyway (it was v4.0) then it was time for mysql too, to be able to use json columns and new stuffs…
When I finished purge/upgrade/install all that, the phpmyadmin alias was broken. I tried everything to get it back to work, the solution was to reinstall apache2 and get a fresh start…

Well, you have to be careful and know what you do. The first time wasn’t successful, I broke the workspace and I deleted it.

I think c9 need to upgrade it’s packages or give a tool to do that without headaches.

Good luck!


Hi, I spent the last week trying to figure it out, scouring the internet, finally I got it working. I shared my instructions here: Laravel 5.3 Installation on Cloud9


Now that Laravel 5.4 is out, I have updated instructions here: