How to get rid of the keybinding for Ctrl+b


#1

Is there any way to get rid of the keybinding for Ctrl+b? (of tmux). It’s very annoying to type Ctrl + b twice to move backward one character on the command line, Emacs, etc.


#2

Open your keymap and remove the binding. :slight_smile:


#3

Correct me if I’m wrong, but there are no key bindings preset for ^ B.


#4

There is one to run the builder it seems.


#5

I’m using Mac, and the default keybinding for “build” is the command B. Besides, the short cut(Ctrl+B) works just fine on the default editor.

The reason why Ctrl+B is not working properly on the terminal, I suspect, is that it uses tmux, the process of which I cannot kill.

Anyway, thank you very much for your kind help.


#6

ctrl-b in terminal is indeed handled by tmux and cannot be changed atm. I am working on a change in the way tmux is launched, which will disable ctrl-b and tmux split panes, statusbar, etc.