How to get jupyter notebook to run on c9?

python

#1

Hello
goal: run jupyter notebooks on c9
issue: jupyter notebook browser URLs do not load and show notebook

what I’ve done:
I’ve installed conda
http://conda.pydata.org/miniconda.html

and was able to run jupyter notebook
The Jupyter Notebook is running at: http://localhost:8888/
BUT I can’t get the jupyter notebook to load properly on any c9 URL.

Here are URLs I’ve tested with results

conda_jupyter-c9-pleabargain-c9.io == no joy
http://conda_jupyter-c9-pleabargain.c9users.io/ == no joy
http://conda_jupyter-pleabargain.c9users.io/= == no joy

I did try the preview in c9. C9 says: “Unable to load http preview” == no joy
I then clicked on open in new tab
http://conda-jupyter-pleabargain.c9users.io:8888/?_c9_id=livepreview0&_c9_host=https://ide.c9.io
connecting… but never loads… ==ultimately no joy

How can I see a jupyter notebook in c9?

Your help is very much appreciated.
thank you
Dennis


Zero active kernels on jupyter notebook
#2

First, do some digging about what IP addresses and ports Cloud9 supports. Then once that’s done (and only after that’s done :wink:) run it with:
jupyter notebook --ip=0.0.0.0 --port=8080 --no-browser

Then open your application URL and there you go :tada:


#3

Thanks for the quick reply!

jupyter notebook --ip=0.0.0.0 --port=8080 --no-browser

and then tried preview
I see
Unable to load http preview Open your page in a new tab Why am I seeing this?

then I tried opening in new tab. URL:

http://conda-jupyter-pleabargain.c9users.io:8888/?_c9_id=livepreview0&_c9_host=https://ide.c9.io

c9 goes to 8888
the fix…
change to 8080…
http://conda-jupyter-pleabargain.c9users.io:8080/tree

it works… thanks

FWIW
here are the install docs I’ve prepared and will publish once I get C9 and jupyter working together.



Inspired by Douglas Starnes (thank you!)

How to install jupyter on Cloud 9 with conda

Cloud9

link:
https://c9.io

create a new workspace
workspace: name it
desc: give it
public: free
blank ubuntu

conda download:
http://conda.pydata.org/miniconda.html

install conda
https://repo.continuum.io/miniconda/Miniconda3-latest-Linux-x86_64.sh

run:
bash Miniconda2-latest-Linux-x86_64.sh

Now close and re-open your terminal window for the changes to take effect.

conda install jupyter

to run jupyter on c9 use:

jupyter notebook --ip=0.0.0.0 --port=8080 --no-browser

http://whateveryourproject-username.c9users.io:8080/tree

http://conda-jupyter-pleabargain.c9users.io:8089/?_c9_id=livepreview0&_c9_host=https://ide.c9.io

links
conda install instructions
http://conda.pydata.org/docs/commands/conda-install.html
http://conda.pydata.org/docs/install/quick.html#miniconda-quick-install-requirements

commands:
jupyter notebook
conda install jupyter


#4

You don’t even need the :8080 at the end of your URL, but you’re free to use it :smile:


#5

I have tried following your instructions, nut continue to get “no application seems to be running here.” The guy in the video did some steps that you do not have in the text that you wrote. Are your instructions complete or do you have to do those other steps in the video?
Thanks for the help!


#6

Ok so I am totally new to this. I followed the instructions but keep getting “no application seems to be running here.” So I have a question: Does this work on a free account or does it require signing up? Could that be the problem?


#7

jupyter installed and running … Many thks!


#8

Happy to hear it.
I must say though, I would only run conda / anaconda on a virt. machine.

The anaconda installation on my local machine played havoc on my settings! :frowning:
good luck!
Dennis


#9

I’m on a paid account with a beefy VM. But http://blog-payne.c9users.io/notebooks/hi.ipynb just says “connecting to kernel” and doesn’t work. The jupyter GUI paints, but I can not run any python. Please help me debug this?

Thanks :slight_smile:


#10

following similar commands jupyter works well, locally, on my Mac. I’d love to use it on c9 please.


#11

I think cloud9 would be wise to develop something akin to JupyterLab