How to get Emmet working


#1

Love C9 but incredibly frustrated that I cannot get emmet working. I went to Preferences-Plugin Manager and it shows Emmet as installed (Enabled=true). I have restarted my workspace but none of the emmet commands I know and love function.

Has anyone else installed emmet and have it functioning (example: .active --tab–>

)?

Any help would be greatly appreciated. I am really enjoying C9 but will likely switch to another offering if I cannot get emmet working … emmet is a powerful time saver.

Thanks!


#2

Never Fails. I post a help request and then figure out the solution. To save others the 1+ hour I spent on this issue, here is a bit more about the problem and solution.

  1. Emmet was installed fine. Challenge is that I am using .EJS files (a templating file format that is very similar to HTML).

  2. C9’s editor (ace?) correctly identified the file as a .ejs file. Looks like C9’s version of emmet does not currently support .ejs emmet commands.

  3. Solution is the change file type the C9 editor associates with .ejs files to HTML. You can do this manually for each file in C9’s text editor. Simply click on file type (EJS) on bottom right hand-side of text editor window. This is same location you set number of spaces a “tab” gives you (2 or 4). You will also see a “settings” cog. In my case, I simply changed EJS to HTML.

  4. PRESTO! Instant Emmet Support!

I am a happy camper again!

Doug Wells


#3

Thanks for posting the solution! I didn’t know Emmet doesn’t support .EJS and would have resigned to writing plain old Emmet-less HTML ( like losing your superpowers ) in Cloud9. Cheers.