How to disable Pylint

python

#1

I tried to disable an annoying pylint warning, but now, pylint is failing.

From my browser’s JavaScript console:

30779: 3964: Error: Command failed: No config file found, using default configuration
    at ChildProcess.exithandler (child_process.js:647:15)
    at ChildProcess.EventEmitter.emit (events.js:98:17)
    at maybeClose (child_process.js:753:16)
    at Process.ChildProcess._handle.onexit (child_process.js:820:5)

#2

To disable Pylint, you can go into settings and use the “Ignore Messages Matching this Regex” setting.

As for the bug you mentioned, these is a fix in place for this that should be deployed in the next day or so.


Note: I changed the thread title so others can search for how to disable Pylint if they need to.


#3

Since today I get this error message (and no linting) regardless of what my “Pyline command-line options” are. :frowning:


#4

@fnkr We launched a fix for this a few hours ago! Using this setting was disabling some defaults and making pylint return an exit code that was not supported.


#5

Ah, I already tought it was something like that. But: I still can’t use pylint. With or without extra command-line options.

29951: 5820: Error: Command failed: No config file found, using default configuration

    at ChildProcess.exithandler (child_process.js:647:15)
    at ChildProcess.EventEmitter.emit (events.js:98:17)
    at maybeClose (child_process.js:753:16)
    at Process.ChildProcess._handle.onexit (child_process.js:820:5)

From my ~/.c9/project.settings:

    # ...
    "python": {
        "@path": "/home/ubuntu/workspace/env/lib/python3.5/site-packages",
        "@version": "python3"
    },
    # ...

#6

It looks like the new version of Pylint is returning different exit codes than it used to, depending on if you have errors, warnings, or other issues in the code. Today we updated our Python linting plugin to cope with this. Please let us know if that doesn’t resolve the issue, @fnkr!


#7

It’s working now, thanks!