How to disable pc speaker sound (beep) in terminal?

terminal

#1

Hello
How to disable pc speaker sound (beep) in terminal Cloud9?


#2

in which workspace do you get the beep? cloud9 doesn’t play beep sound in terminal


#3

Hello

I use ide.cs50.io


#4

turn off “audible terminal bell” from the settings


#5

thank you very much

PS. Speaker was changed to beautiful beep it is so cool :slight_smile:


#6

Hi, I’m actually having the reverse problem. The beep is on the terminal and I want to take it off. I find it distracting. I’ve looked under the same settings and I’m only seeing this: <img src="/uploads/trydiscourse4/original/2X/b/bad8e3ad040c83d6db1406d162dc131f0c5e8691.png" width=“590” ">
Help please? :slight_smile:


#7

try remove cache and cookies in browser and reload cloud9, after that check settings.
I try and this help me.


#8

Figured out the problem was an init script calling a beep function. I deleted one character to disable to script. Problem solved. :grin:

Edit: If someone else has the same problem, go to IDE(top left menu)>“open your init script” and then disable the function that mentions “beep”. Good luck!


#9

Has this feature been removed? I am unable to find CS50/IDE Behaviour in my workspace :frowning:

One more question, what should I do to make my workspace terminal beep or produce a sound?


#10

it is only in cs50 workspaces, to get the same in other workspaces use Can I get the command line terminal to Beep?