How to connect AuroraDB AWS to my Node.js app


#1

Having problem with connection to RDS AWS … throwing . connection . error … I don’t .know what todo may be proxy servers…I’ve already tray’d to put setTimeout for about 30 000 ms :globe_with_meridians:
if (err) throw err;
^

Error: connect ETIMEDOUT
    at Connection._handleConnectTimeout 
 (/home/ubuntu/workspace/node_modules/mysql/lib/Connection.js:419:13)
    at Socket.g (events.js:292:16)
    at emitNone (events.js:86:13)
    at Socket.emit (events.js:185:7)
    at Socket._onTimeout (net.js:338:8)
    at ontimeout (timers.js:386:14)
    at tryOnTimeout (timers.js:250:5)
    at Timer.listOnTimeout (timers.js:214:5)
    --------------------
    at Protocol._enqueue (/home/ubuntu/workspace/node_modules/mysql/lib/protocol/Protocol.js:145:48)
    at Protocol.handshake (/home/ubuntu/workspace/node_modules/mysql/lib/protocol/Protocol.js:52:23)
    at Connection.connect (/home/ubuntu/workspace/node_modules/mysql/lib/Connection.js:130:18)
    at Connection._implyConnect (/home/ubuntu/workspace/node_modules/mysql/lib/Connection.js:461:10)
    at Connection.ping (/home/ubuntu/workspace/node_modules/mysql/lib/Connection.js:217:8)
    at /home/ubuntu/workspace/sqlreplica.js:170:16
    at callbacks (/home/ubuntu/workspace/node_modules/express/lib/router/index.js:161:37)
    at param (/home/ubuntu/workspace/node_modules/express/lib/router/index.js:135:11)
    at pass (/home/ubuntu/workspace/node_modules/express/lib/router/index.js:142:5)
    at Router._dispatch (/home/ubuntu/workspace/node_modules/express/lib/router/index.js:170:5)

#2

Do you have your AWS Security Groups set up correctly to allow inbound connections to your RDS instance from your Cloud9 workspace?


#3

Yes… and I also add my IP in CIDR4 folder as a second one. … now . the . amazone support suggest to edit route options.