How to change tabs with a keyboard shortcut


#1

None of the suggested keyboard shortcuts for changing tabs seems to work for me. I’m using Chrome and Mac OS 10.10. Anyone else having issues? ⌥-Tab just removes focus from the current tab.


#2

It seems I had some project specific keybindings. I’m not sure how they were set but I found them and they work :).


#3

This is the current and expected behavior for switching tabs with Alt + Tab.

If you’re having issues with this, here are a few things to check:

  1. Give it a shot in an incognito window to make sure none of your browser extensions are affecting it.
  2. Make sure you didn’t change that keybinding to another action by checking in Settings > Keybindings
  3. Open up the browser console and reports any errors or messages you see there.indent preformatted text by 4 spaces

Edit: I was a minute late :slightly_smiling: So sounds like it was number 2 here :point_up:


#4

On OS X, you can use +] and +[ to cycle through editor tabs.


#5

Thanks guys! I appreciate your responses.


#6

This is not working for me. Im in windows with chrome as a browser


#7

@rodolvelasco on Windows, the shortcuts are probably different. Try Ctrl+] and Ctrl+[ instead.


#8

This discussion about Tabs has some information about the Cloud9 Keybinding system and how to remap them for your use:


#9

It worked for me in my chromebook with Crtl+[ and Ctrl+]. Thanks @xoob

In windows with an Latin American Keyboard I mean the one with the letter “ñ” to the right of “l”, I had to change the keybindings to because [ and ] couldn’t be accessed by Ctrl+Shift+key related to [ symbol my keyboard is like this

In conclusion, if you have a keyboard that access to [ with key combination (example Shift+[) you will need to access change the keybinding because Crtl+Shift+[ wont work for some reason.


#10

I was having a bad time because command+number was captured by c9 and I couldn’t change between chrome tabs. If someone else is facing the same problem, my solution is to use command + shift + [ or ] to navigate throughout chrome tabs


#11

you can also disable shortcuts you don’t like from command manager