How do I make git ask for a username/password instead of an ssh key?

bitbucket
git

#1

I use bitbucket for my source control. When I add my c9 ssh key, it expects all connections to that bitbucket account to use ssh keys. How do I get the c9 git to ask me for my username/password which each request to bitbucket?


#2

Hi,

The cloud9 git is like any other git installation, so you can use any common solution like the one in the link: http://stackoverflow.com/questions/25735957/how-do-i-make-git-ask-for-a-username-and-password-every-time-i-push

I hope this helps!

Dana


#3

I’ve tried that, but I don’t see a credential section or helper in the project config file, and I don’t see a .git-credential-store anywhere.

Edit: To clarify, it doesn’t have my username/password stored anywhere. I’ve never given that login information to c9.


#4

Did you also try one of the solutions in the comments?


#5

Yes, I’ve tried them. None of them worked. I’ve never provided my password through c9, so it can’t be cached somewhere.

I haven’t made any changes to git. I’ve just been following through chapter 3 of https://www.railstutorial.org/book, which seemed to use the ssh key out of the box.


#6

Why don’t you just pull from the git repo’s individually when you want to create a new workspace? You can clone a workspace from the repository link bitbucket gives you on the front page of that repo which is not SSH.

If you are created a new workspace from the repo it will ask for your username and password in the console once the workspace has been allocated.

Also you can just create a blank workspace and use command line to import your repo too which I think is much easier.


#7

The problem is it’s not asking me for my username and password. It just says

Permission denied (publickey).
fatal: Could not read from remote repository.

I already have a local workspace with my code in it. I’m currently trying to push my changes.

Does this have anything to do with the settings in the Rails Tutorial template?


#8

Nah, wouldn’t have anything to do with Rails. Why don’t you remove the ssh stuff from your c9 configuration and set a new remote origin with

git remote set-url origin https://github.com/USERNAME/OTHERREPOSITORY.git


#9

Obviously with a bitbucket git url instead of github lol


#10

How do I remove the ssh stuff from my c9 configuration?

My origin is already set to git@bitbucket.org:nsinha/sample_app.git. Is that incorrect?


#11

Solution.

origin was set to git@bitbucket.org:nsinha/sample_app.git

I changed it to https://nsinha@bitbucket.org/nsinha/sampled_app.git and it worked.