How can I install a shared library (libz.so) in my workspace?


#1

I’m using Cloud9 to develop moble apps using Ionic (Cordova) and when I go to build the app, I’m getting the following error.

/home/ubuntu/opt/android-sdk-linux/build-tools/23.0.2/aapt: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory.

I did a google search and based on what I read, installing package lib32z1 on ubuntu will solve this issue. My account doesn’t have permissions to install the package so can someone from Cloud9 do it for me?


#2

Per the official Ionic installation guide, you should install some dependencies to your workspace before you can use the Android SDK. Here is the command you should run:
sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0

You should not be asked for a password for sudo. If you are asked, you may try a blank password or your Cloud9 account password.


Install Android SDK on C9
#3

Well, isn’t this embarrassing. :blush:

I tried a number of times and it didn’t work. Cut-n-paste your command and it worked perfectly.

Thanks!