How can I disabled xdebug in c9 workspace?


#1

I’m executing a composer update command for updating symfony version but cpu and memory are to maximum and the process is taking too long.


#2

In your php.ini, set xdebug autostart to false

xdebug.remote_autostart=0  
xdebug.remote_enable=0

Disable your profiller

xdebug.profiler_enable=0

See also:

  1. How to disable Xdebug
  2. How to disable remote debugging for single PHP file

#3

I already did this by adding those lines in php.ini that is in workspace folder and message still appeared when I executed composer update command.


#4

You may need to comment out zend_extension=xdebug.so from /etc/php5/cli/conf.d/20-xdebug.ini (this path depends on which version of php you are using). For apache xdebug is enabled in /etc/php5/apache2/conf.d/20-xdebug.ini