How can I bring back this bar in editor mode?


#1

Or is it a bug and mine has disappeared?

See first pic, at the bottom of the code editor window.

Contrast this with this here I found online:

#https://manual.cs50.net/ide/night-mode.png

As you can see, instead of just the line numbers, there’s the settings icon, spaces, C and C++. These are options I used to have but now don’t have. I find them necessary for my work, so I’m wondering if I can bring them back.


#2

Hi @hivestrung, apologies for the inconvenience! We’ve recently simplified the user interface a little bit more.

Re syntax highlighting, the code editor is smart enough to automatically detect that based on the file extension and some shebangs.

Re tabs and spaces, you should still be able to reach that from CS50 IDE > Preferences > Code Editor.

If you’d like to increase the font size of your code editor and terminal, you should be able to achieve that by hitting Ctrl (or Cmd) + or Ctrl (or Cmd) - respectively. Alternatively, you may use View > Font Size. Let us know if you need further assistance!


#3

Hi!

Oh nooooooo this is a tragedy. Doesn’t seem any simpler at all because all these shortcuts are so difficult to reach now. :frowning: But we march onward in the name of progress…

How about wrapping to print margin and etc? That was extremely useful and tbh I’m finding it difficult to get my work done with no wrapping. How do I change the settings for that now?

Thanks