Heroku: could not migrate


#1

Hello,
about 2 days ago, I could not and still can not
migrate my app to heroku.
I’ve contacted to heroku and they said that your CLI is outdated.
Would you please update your CLI?
thanks

//Errors as below:
heroku version
▸ heroku-cli: This CLI is deprecated. Please reinstall from https://cli.heroku.com
heroku-toolbelt/3.43.16 (x86_64-linux) ruby/2.3.0
heroku-cli/6.11.7-4cda136 (linux-x64) node-v7.10.0
▸ no plugins installed
You have no installed plugins.


#2

I’ve got response from heroku:
“Hi Tatyana
The current stable version of the heroku CLI is:
$ heroku --version
heroku-cli/6.11.8-080214e (darwin-x64) node-v7.10.0
It seems like your CLI is either outdated, or has become corrupted, and it might be easier for you follow our uninstallation instructions”

But my CLI is updated (see below) but Cloud 9 CLI is outdated(see below):

How to update Cloud 9 CLI and get rid from bug?
Thanks.

//my CLI as below:

~ tatyana_pol$ heroku --version
heroku-cli/6.11.8-080214e (darwin-x64) node-v7.10.0
$

// Cloud 9 CLI as below:

(master) $ heroku --version
▸ heroku-cli: This CLI is deprecated. Please reinstall from https://cli.heroku.com
heroku-toolbelt/3.42.42 (x86_64-linux) ruby/2.3.0
heroku-cli/6.8.5-e6953b2 (linux-x64) node-v7.10.0
▸ no plugins installed
You have no installed plugins.


#3

Also I was advised to update
using sudo apt-get update heroku
it doesn’t work
sudo apt-get update


#4

I got form heroku that cloud9 should update the original version. and app. could be updated as well by user:
"…it can be updated via sudo apt-get update heroku (it may be under a different name such as heroku-cli or heroku-toolbelt)"

I’ve tried sudo apt-get update but got error as below:

heroku –version
▸ heroku-cli: This CLI is deprecated. Please reinstall from https://cli.heroku.com
! Heroku client internal error.
! Search for help at: https://help.heroku.com
! Or report a bug at: https://github.com/heroku/heroku/issues/new

Error:       no implicit conversion of nil into String (TypeError)
Command:     heroku –version
Version:     heroku-toolbelt/3.42.42 (x86_64-linux) ruby/2.3.0
Error ID:    e49a8231f4974d7dba980d2f4bcb320d

More information in /home/ubuntu/.heroku/error.log

Any suggestion how to proceed?
If there is no answer, I assume that is nothing can be done until bug fixed.
thanks.


#5

I don’t have the error as described in the previous post but got the
same message about out dated version heroku as below:

/workspace $ heroku --version
▸ heroku-cli: This CLI is deprecated. Please reinstall from https://cli.heroku.com
heroku-toolbelt/3.42.42 (x86_64-linux) ruby/2.3.0
heroku-cli/6.8.5-e6953b2 (linux-x64) node-v7.10.0
▸ no plugins installed
You have no installed plugins.


#6

I be able to update heroku.
thanks.


#7

As I wrote I be able to update heroku but on workspace rails tutorial where I’ve updated, I’ve got as below:

“Your workspace is running out of quota. Please make some free space”

I deleted some app, but still could not operated this space.
I am running out of space because of updating or some other reasons?
How to fix it?
thanks.


#8

Are you using a free dyno or did you sign up for a paid option? The free dyno which each pushed application runs on has limited resources. That sounds like the quota comment. Free space up or get more dynos. I think if you are running real apps in Heroku and volume becomes a reality the processing load is split up across multiple dynos. I only use a free dyno myself and have a very small resource need. I only get the one dyno for my app. I haven’t received the quote message.


#9

Not I use free space in heroku.
The problems erased when i could not
migrate to heroku : it was said on command line that heroku app is outdated.
So, I’ve update this app; but after updating I started to get warnings about not enough space.
I’ve checked out - all my space in zip is 56.3 MB.
Why I got those warnings abut not enough space?