Heroku Command not working - Fixed

heroku

#1

Hi,

I keep getting this error for Heroku Command - framework ruby / rails

/home/ubuntu/.nvm/versions/node/v4.2.1/lib/node_modules/heroku-cli/node_modules/cli-engine/lib/cli.js:73
async run() {
^^^

SyntaxError: Unexpected identifier
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:414:25)
at Object.Module._extensions…js (module.js:442:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:311:12)
at Module.require (module.js:366:17)
at require (module.js:385:17)
at Object. (/home/ubuntu/.nvm/versions/node/v4.2.1/lib/node_modules/heroku-cli/bin/run.js:2:13)
at Module._compile (module.js:435:26)
at Object.Module._extensions…js (module.js:442:10)

Does anyone have an idea how to fix this issue?


#2

What happened: I got a message that my Heroku Toolbelt is outdated. I googled how to update the Toolbelt but I think I must have installed an incompatible version for Ruby on Rails.

How I solved it: I reverted the default Heroku toolbelt environment for Ruby on Rails via Menu > Run > Run with > Default Ruby on Rails.

Everything appears to be working fine now.