Help C++11 Runner

runner
cplusplus

#1

Hi, first I start saying that i’m a novice in programming. I’m studying from a book where c++11 libraries are used.
I changed the line of the “Runner:C++(simple)” but it keep giving me this error:

error: range-based ‘for’ loops are not allowed in C++98 mode

I don’t understand why my runner keeps using c++98 after I modified the flag.

Can someone help? I really don’t know what to do.


#2

Try closing the runner and file then reopening and running again. Sometimes the runner doesn’t update if you don’t close it.


#3

I found that closing the runnner and opening is not always enough.

Was it for you?

I had the same thing while trying the exact same thing… ( c++ 11 runner… )
I just restart c9… but if i dont have to do that next time i write or edit a runner that would be great!


#4

I found a topic with this command

g+±4.8 --std=c++11 Test.cpp

It works with other little files that I wrote without the need of c++ 11. The problem is that when I try to compile like a C++11 Vector is giving me weird bugs. The command seems to work but I can’t execute the program.
It tells me something like

bash: ./Vector: No such file or directory

or just executes another program, I tried to close and reopen file and terminal but still not working. As intended at least


#5

The runner edited with --std=c++11 is not working too, even after restart. :frowning:


#6

I installed g++5, I noticed that the compile file is always a.out . I used to execute files with ./File . Is there a way to link the file name with the compiled one instead of a.out for each one?


#7

ok I found the solution by myself :slightly_smiling: . Really sorry for the spam!
Thanks for the support!!