Going bald with github authentication

ssh
github

#1

I am comfortable with jekyll development and github on my Mac but have recently moved to a chromebook (for the disposability of the machine and not wanting to take a £1200 machine everywhere)

I found Cloud9 and played around with it and decided that it was a good solution (better than messing around with chromebook developer mode and chroots)

I have got a project i’m working on for a new client and have decided to have the following workflow

  • develop on cloud 9
  • travis CI for testing output, linting etc before automatically performing a google FIREBASE DEPLOY to the end server

I have got the main part of the workflow running but keep having the same problem appear over and over

$ git add . && git commit -m “tweaking travis” && git push
[master fc1ea43] tweaking travis
** 1 file changed, 1 insertion(+)**
Warning: Permanently added ‘github.com,192.30.253.113’ (RSA) to the list of known hosts.
Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I am having problems between a combination of cloud9 github and travis

Is there a way of permanently caching authentication within an environment such that :

  • when the environment moves between virtual machines I can still ‘git push’ without authentication ?

I have tried setting up a ssh key and that expires once I leave the keyboard for a while (I’m guessing Cloud9 c9.io spins down the virtual machine and when I come back it appears on another thus presumably invalidating the ssh key)

I have also tried setting a GH_TOKEN in the environment variables without any success

Any ideas?


#2

Is your Cloud9 account Connected to Github? This typically adds your key to Github automatically. If that doesn’t work, you should just be able to add your Cloud9 SSH key to your Github account and then go from there.