Getting an error when installing a python library

python

#1

When I try installing the python-mnist library by typing the following in the bash:
sudo easy_install python-mnist
I get the following error:
ValueError: bad marshal data (unknown type code)
Does anyone know how I should install mnist?