Get requests are blocked by the new preview screen


#1

Hi there, I use the application preview services through postman by making GET requests and POST requests to test an API I am building. Recently you added a screen that requires users to accept that the application is a preview before actually returning the preview.

This is a problem because get requests made to the service from outside a browser returns this HTML page. Is there any way to disable this feature and revert it back to what it was? I have been developing this API using cloud 9 for almost a year now and with this new system I may have to move my project off the cloud 9 service to test API calls, which would be a huge setback.

Thanks!


#2

I found a temporary workaround wherein I copied the URL that the open app button redirects to and ran a GET request through my request testing application. Requests that follow that request are now functioning as usual.

https://c9users.io/_user_content/callback/preview?redirect={{URL TO APP HERE}}&expires=1496845305321&nonce=SOMEHASHVALUE&signature=SOMEHASHVALUE

This solution is a hack. And from what I can tell from the URL it may have an expiration date.
I’m curious if you have any plans to support people who make API calls this way… or was the idea to not use the service this way… or maybe this was an oversight?

In any case, I’m getting back to work! Thanks!


#3

Yeah, same problem here. I think that screen is useless and just makes my life difficult.


#4

I’m having the same issue. I tried the hack however it doesn’t seem to be working in my environment. Hopefully this is fixed soon!


#5

The same here - problem started two hours ago.


#6

Also happening here. Same timeline, same issue. :sweat_smile: :sweat:


#7

Just to provide a response from c9:

Hi there,
Apologies for the trouble. We deployed a change that caused some issues with redirects and a fix is now working its way through the system. It will take a few minutes for the fix to be deployed everywhere, but sit tight! We’re on it!
Kind regards,
Dan
Cloud9 IDE


#8

This is a major problem for use developing APIs what is the purpose of this? I don’t want to go back to local development.


#9

The page is meant to be shown only when opening preview of html pages in the browser. It both helps new users to understand how to use the preview, and prevents hosting of phishing sites on cloud9.
You should not see this when developing APIs.
The issue with postman is fixed now, if you see the warning page from postman, or from another tool, please tell us the steps to reproduce the issue.
As a temporary workaround you can either set user-agent header to something without Mozilla and Webkit words, or set accept header to something without text/html, or add a cookie.


#10

This “Preview page” is an annoyance that should be able to be disabled.

I personally thought this was possible using a flag in Preferences. Since I could not found it I thought it was behind a paywall and subscribed to the paid service, but, since is not, C9 IDE can not help me here.

Please remove the “Preview Page” doesn’t help, or at least give a flag to disable it completely.

Thanks


#11

If you are a premium user, please contact the support@c9.io, they should be able to help.


#12

I am, I did. I plan to use C9 IDE to power remote devs across the globe, but that little problem is stoping me from doing it (with C9 IDE at least)