Flask-Security Install Error Help


#1

Hi, Im trying to install Flask Security. Unfortunately I get an error while trying to install it, and I am unclear of the reason why.

error: could not create ‘/usr/local/lib/python2.7/dist-packages/flask_security’: Permission denied


Cleaning up…
Command /usr/bin/python -c “import setuptools, tokenize;file=’/tmp/pip_build_ubuntu/Flask-Security/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-YaDRDT-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip_build_ubuntu/Flask-Security
Storing debug log for failure in /home/ubuntu/.pip/pip.log


#2

try running the command with sudo


#3

Ahaha thanks a lot for the help.