File is not saved despite it says so


#1

Hi,

I got a bug a few weeks ago where I lost an afternoon of coding because my file was apparently not saved.
I thought this was a strange “exceptional” bug. But now I’m encountering again.

This time, I can “see” it!
The “code pane” shows the code like you typed. When you type it and save it, you see the green dot and “All changes saved” message. However, if you go to the terminal and make a “cat myfile”, you see the file unchanged!

Another way to see it is by copying the file in the “workspace file explorer panel”. The result will be different than what you are currently editting. Closing it and reopening it also looses your changes.

PS: on this workspace, I have the experimental “Changes Panel”, dunno if it has something to do with it though.

PS2: this was the workspace/file where it happened: https://ide.c9.io/xarn/shelve2 - finder/finder.py


#2

Thanks for the report here. I’ve gone ahead and made and internal report on this so we can track it and I’ll post updates here as they come.


#3

I had the same thing happen today. With me it was saving the previous update, not the most recent update.


#4

We’ve released a patch a few hours ago that should fix this. If you notice it happening again please let us know.


#5

Thanks. Better late than never.

I haven’t encountered it so far anymore, looks good.


#6

The bug is still here… few minutes ago it’s happened to me while coding in Ruby. The layout of my application was not changing despite the changes to the code in the view file. I had to close and open the file again in order to notice no one of the changes i did was saved…


#7

What workspace and file did this happen to? And at approximately what time did it occur? I’ll go over our logs and investigate.


#8

It was something like 10 am (utc +2), but I don’t remember the exact time, sorry if I can’t be more precise…
The file was app/views/shared/_header.html.erb in my only workspace (RoR).

EDIT: I forgot to say it’s not the first time it’s happens… I had the same issue a couple of time before yesterday.


#9

Happens again here too, it’s a disaster !!! You loose code without noticing it !!!

When I started, I was amazed by cloud9, then I found a couple of quirks …and lastly this. Honestly, you cannot trust an editor which writes “saved” and does not !!! This is silently loosing your code !!!

In the browser console, errors are flying around too. I Picked up, perhaps some will help you:
https://ide.c9.io/xarn/temser#browser_logs

From what I read, I suspect it goes nuts after a disconnect / reconnect, despite stating otherwise.


#10

It happened to me twice in two days. I login from one location, work, and when I connect from home. nothing saved. First time it was ok, because the content was not updated only in the c9 editor (no matter how many times I restarted the vm) and I fixed it by cloning my workspace. But this time I can’t recover my file.
Is it possible to recover my data ?


#11

I am experiencing this issue too. For the first time. Working with file that has 8000+ lines of code. And i can’t get it to work, open/close file, restart ide… same, it doesn’t save.


#12

Is there any update on this? I run into this constantly. Happy to provide further details if needed.


#13

This just happened to me and has been happening recently. It never happened pre- the last few weeks. There is definitely nobody in the workspace in me, and I manually save over and over and sometimes it just doesn’t save. I can provide information on the specific workspace(s) if desired.