Error when running ruby project


#1

Hello,

I am receiving an error when trying to run my first cloud9 project.
Freshly downloaded from github.

Thanks for the help.

RubyDep: WARNING: Your Ruby is outdated/buggy.
RubyDep: WARNING: Your Ruby is: 2.3.0 (buggy). Recommendation: upgrade to 2.3.1.
RubyDep: WARNING: (To disable warnings, see:http://github.com/e2/ruby_dep/wiki/Disabling-warnings )
Exiting
/usr/local/rvm/gems/ruby-2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:293:in require': cannot load such file -- rack/handler/install (LoadError) from /usr/local/rvm/gems/ruby-2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:293:inblock in require’
from /usr/local/rvm/gems/ruby-2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:259:in load_dependency' from /usr/local/rvm/gems/ruby-2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:293:inrequire’
from /usr/local/rvm/gems/ruby-2.3.0/gems/rack-2.0.1/lib/rack/handler.rb:74:in try_require' from /usr/local/rvm/gems/ruby-2.3.0/gems/rack-2.0.1/lib/rack/handler.rb:16:inget’
from /usr/local/rvm/gems/ruby-2.3.0/gems/rack-2.0.1/lib/rack/server.rb:300:in server' from /usr/local/rvm/gems/ruby-2.3.0/gems/railties-5.0.0.1/lib/rails/commands/server.rb:112:inprint_boot_information’
from /usr/local/rvm/gems/ruby-2.3.0/gems/railties-5.0.0.1/lib/rails/commands/server.rb:73:in start' from /usr/local/rvm/gems/ruby-2.3.0/gems/railties-5.0.0.1/lib/rails/commands/commands_tasks.rb:90:inblock in server’
from /usr/local/rvm/gems/ruby-2.3.0/gems/railties-5.0.0.1/lib/rails/commands/commands_tasks.rb:85:in tap' from /usr/local/rvm/gems/ruby-2.3.0/gems/railties-5.0.0.1/lib/rails/commands/commands_tasks.rb:85:inserver’
from /usr/local/rvm/gems/ruby-2.3.0/gems/railties-5.0.0.1/lib/rails/commands/commands_tasks.rb:49:in run_command!' from /usr/local/rvm/gems/ruby-2.3.0/gems/railties-5.0.0.1/lib/rails/commands.rb:18:in<top (required)>'
from bin/rails:4:in require' from bin/rails:4:in

Process exited with code: 1


#2

Hard to say what’s the issue here.

What kind of project is this? Rails?

Would be helpful if you can provide the Rails version and Ruby version in your workspace. Also your Gemfile.


#3

@BigChief45 thanks for the response!
Yes, its a ruby project - currently running 2.3.0
(this works on my local on my mac, trying to migrate it over to C9.io)

GEM FILE:

source 'https://rubygems.org
ruby ‘2.3.0’

Bundle edge Rails instead: gem ‘rails’, github: ‘rails/rails’

gem ‘rails’, '~> 5.0.0’
gem ‘puma’, '~> 3.0’
gem ‘sass-rails’, '~> 5.0’
gem ‘uglifier’, '>= 1.3.0’
gem ‘coffee-rails’, '~> 4.2’
gem 'jquery-rails’
gem ‘turbolinks’, '~> 5’
gem ‘jbuilder’, '~> 2.5’
gem 'bootstrap-sass’
gem ‘devise’, '~>4.2.0’
gem ‘roo’, '~> 2.4.0’
gem 'resque’
gem ‘resque-web’, require: 'resque_web’
gem 'therubyracer’
gem 'less-rails’
gem 'twitter-bootstrap-rails’
gem 'slim’
gem ‘sinatra’, github: 'sinatra’
gem 'sidekiq’
gem 'rack’
gem 'railties’
gem 'activesupport’
gem ‘command-runner’

group :development, :test do
gem 'sqlite3’
gem 'listen’
end

group :production do
gem 'pg’
gem 'rails_12factor’
end

Windows does not include zoneinfo files, so bundle the tzinfo-data gem

gem ‘tzinfo-data’, platforms: [:mingw, :mswin, :x64_mingw, :jruby]


#4

solved, it was the runner… had the wrong runner selected.