Error: protocol version mismatch (client 8, server 7)


#1

Was working fine and suddenly starting processes gives this error.
“protocol version mismatch (client 8, server 7)”

Reloading/refreshing doesn’t seem to help.


#2

this sounds like an issue with tmux, are you seeing it on ssh or hosted workspace, and did you update tmux recently?
One workaround is to kill all existing tmux sessions by running tmux kill-server


#3

This looks like the same issue I’m having. The bug report I made details it more. For me, it’s a cloud9 server, not my own server.


#4

The error was in the hosted workspace, I managed to fix it by finding and using the ‘restart workspace’ option.


#5

Restarting the workspace worked for me also. Thanks so much!