Error connecting to my GitHub account

github

#1

I’m a new customer, just getting oriented, so no critical issue here time-wise… I tried to connect to my GitHub account and did the authorization step but then get a blank screen on the pop-up window until I do a refresh request and this error message appears:

===
failed to fetch user profile (status: 401 data: {“message”:“Requires authentication”,“documentation_url”:“https://developer.github.com/v3”})

I’ve closed the pop-up, refreshed the Connection Services page, tried again a couple times but get the same result. I then checked my authorized apps at GitHub and Cloud9 is listed. I revoked its authorization and did the connection again and got the same result with the same message above with Cloud9 listed in the authorized apps list but unable to connect.


#2

I’m Getting the same issue. Using Win10 and Google Chrome if that helps.


#3

Hi @ellisgeek… are you still having this issue? Our problem seems similar to what has been happening with some folks using BitBucket, too.

I am getting my “sea legs” of familiarity w/ c9 and getting to where GitHub integration is important.

I am on fully patched Win 8.1 x64 and tried both Chrome and Firefox browsers to see if that made any difference in the handshake but got the same result.

When I go to GitHub and look at my settings and applications that have access authorization, I see Cloud9 but this authorization is not allowing the c9 IDE to show that I have GitHub as a connected service.

I hope @bradydowling or @mutahhir or someone else at c9 looks into this soon and gets it working.

A reply cookbook/work-around posted here if there is no quick fix to get this feature working as intended would be helpful.

But if there is any way I can help with testing, etc. please do not hesitate to ask.

– Jim –


#4

Thanks for the mention. You’re both using Windows but I’m doubting that’s part of this. Give this a go:

It’s also possible that your Github account is attached to another Cloud9 account. Many users create a separate Cloud9 account accidentally by clicking the Github button on sign-in when they haven’t actually connected their Github account yet. If you’re afraid this is the case, you might try to login with Github. Whether it creates a new account or logs into an existing one, delete that account and Github should now be set free!


#5

Hi @bradydowling… That worked! :slight_smile:

ISSUE SOLVED.

For the record, I have a vague memory of “peeking” at the GitHub linkage during my initial account creation and backed out thinking I’d “kick the tires” a bit before complicating things with account linkages, etc. So I did a “drive by” screw-up on myself that your process has helped untangle. With that peek-but-no-authorization, the “die was cast” and all my subsequent connection attempts went nubs up. So as recommended, here’s what worked:

  1. I logged out of C9.

  2. I then logged back in and clicked the GitHub logo in the sign-in screen and let the process create a new free C9 account now associated with my GitHub account.

  3. I then deleted that account and revoked its authorization in GitHub.

  4. I logged back in to my intended/new C9 account and went to my Account Settings’ Connected Services pane and did the Connect button again for GitHub and WHAMO! Success!

All my GitHub repos are showing as expected, etc. Onward to more learning/exploration!

Thanks for the help.

– Jim –


#6

:dizzy: Booyah! :boom:


#7

I have a similar issue.
I followed you suggestion, revoked the application auth from my github account.
I logged in with my current c9 account, pressed the “Connect” button on the dashboard for Git Hub.
I was presented with an authorization screen so allow c9 access to my GitHub information.
When I clicked authorize, I was again met with a blank screen.

I am currently usin C9 through edX’s CS50x course (cs50.io)

My concern is that I am required to log in using my edX credentials (when I direct my browser to cs50.io) the page is redirected to https://openid.edx.org/openid/provider/login/
So, I am not logging in directly through the C9 portal.

Could this be the cause of my problem?