Emmet support in Vim


#1

Does someone use Emmet with Vim? I’m trying to use it but when I try to complete using Emmet I get the error

option completefunc is not set

Any help would be awesome, thank you!


#2

As far as I know, Emmet is only supported in default keybinding mode in the Cloud9 editor. In other words, I think it doesn’t work in Vim…but I could be wrong and I’m sure there’s some way to make it work. Are you using Vim mode in the editor or vim from the terminal?


#3

Typing i ul>li*3 Tab works in vim mode for html file. For which language mode are you trying to use emmet?


#4

HTML, it doesn’t work for me.


#5

Then it must be a bug, if you tell us more about it we may be able to fix it.
Did you try exactly the sequence above (i to enter insert mode, type ul>li*3 press Tab) or something else?

option completefunc is not set

where do you see this error, in browser console or a popup?


#6

The error was caused by a config on .vimrc, but I can’t use Emmet, I did exactly what you said and it just tabs the 2 spaces defined.


#7

@Oxyrus Are you using Vim mode in the cloud9 editor or vim from the terminal? Cloud9 doesn’t use .vimrc so it seems like you are talking about terminal. The editor you get by running vim in terminal is just the default installation of vim on ubuntu It is not related to cloud9


#8

I set the keyboard to Vim mode but I run it from the terminal, not sure how it should work


#9

Its better to use cloud9 editor instead of running vim in the terminal.