Elastic Search installation & usage

workspace

#1

Hello !

I wanted to know how to access an installed elasticsearch instance, I installed and started it so it gave me this output :

[2016-08-30 07:20:00,642][INFO ][http                     ] [Hussar] publish_address {127.0.0.1:8081}, bound_addresses {127.0.0.1:8081}, {[::1]:8081

So I followed the elasticsearch tutorial ad then I did :

curl 'localhost:8081/_cat/nodes?v'

And the output was as expected :

host      ip        heap.percent ram.percent load node.role master name   
127.0.0.1 127.0.0.1            6          91 5.86 d         *      Hussar  

But when I try to access https://myproject.c9users.io:8081/_cat/nodes?v I get a "No application seems to be running here!"
What did I forgot ?

Thanks for reading


#2

Ok so I installed it via the apt-get process so if I get it right the elastic server is started via Upstart.

When I curl it I get what i want from the bash console but it seems I can’t access it via URL.

Any idea why ?


#3

Which URL are you using?


#4

I found the solution. The problem was that ElasticSearch was not listening to the right network.

I added
> network.host: 0.0.0.0

in the elasticsearch.yml config file and it works now !!

I hope this will help other people =)


Installing ElasticSearch into a workspace
Installing ElasticSearch into a workspace
#5

hi @Sladix recently Im trying to implement elasticsearch and Im getting error just like the one you had. I added network.host: 0.0.0.0 to elasticsearch.yml and still not getting the error fixed… So Im wondering if you did anything else other than adding network.host: 0.0.0.0.

Thanks in advance