Educational Plan - Error 404 and Error 502 when attempting to access team members workspaces


#1

Hi,

C9 has been wonderful in allowing my students to get up and programming in PHP in record time. I have the Education Plan and am experiencing the following issues that I hope someone can help with

  1. When logged and I attempt to view my team members workspaces I am receiving Error 404. Previously I would have been able to view the workspace and request editing rights, this is not available to me.
  2. My team members are reporting receiving the following errors when attempting to preview their work on the server.
    • page cannot be proxied
    • “Error 502 - bad gateway”

On a positive note my private workspace is working fine :slight_smile:

Any assistance you can provide would greatly assist.
Kind regards,
Alex


#2

Hi Alex,

I can try to help. Some questions to get more background on the issues you are seeing:

  1. Have your team members shared these workspaces with you? When was “previously”? Is it more than a few months in the past?
  2. Is there a pattern in when you get these errors? Or does it happen intermittently?

Dana


#3

Thanks Dana,

A team created in Sept 2016 appeared to work correctly while a team created in Jan 2017 does not. In Sept 2016 I was able to click on a workspace in my team and request access. When I click “open” on a workspace belonging to one of my Jan 2017 team I am receiving Error 404. My students have not yet initiated sharing from their end yet but I have asked one of them to do so by following this link https://docs.c9.io/docs/share-a-workspace.

Both these errors identified in the original post occurred multiple times today.

Thanks for your help :slight_smile:


#4

Hi Dana,

404 error - I believed that if I click on a teammates workspace from within the cloud 9 dashboard that I should get the option to request to share the workspace instead of getting a 404 error is that correct?

502 error - this was caused by an infinite loop in a php script which I should have seen and is now resolved.

Kind regards,

Alex