Editor - Cursor acts very wierdly


#1

Hello, I don’t know why this is happening only in my Chromebook all of sudden (it’s okay in my Desktop and was okay in my Chromebook few days ago).

In my Chromebook (I use Toshiba Chromebook 2), when I use Cloud 9 IDE, the font-spacing is not correct. Just look at the screenshot.

I put cursor on ‘data’ and cloud 9 IDE shows all of same ‘data’ object. but as you can see that box, is little bit biased to left side.

So whenever I want to select that ‘data’, I should exactly select that box.

Same situations happen all the ways. When I clicked last character of a line, the cursor goes to left so that I don’t know which character exactly I’m pointing at right now. It’s really terrible, and I don’t know why this is happening all of sudden (it was okay like some days ago) to my Chromebook. It’s okay in Desktop, but Chromebook needs Cloud 9 much more ;(


#2

Hi,

I’m not sure what’s going on, but it appears to be due to a missing font. Did you recently change the preferences for Cloud9’s editor font?

You can access Cloud9 preferences by using the menu Cloud9 > Preferences

Then visit User Settings > (Editors) > Code Editor (Ace)

Within that list, you’ll find a field for ‘Font Family’. Can you check if the fonts listed there are available on your system?

The default font family list is:

Monaco, Menlo, Ubuntu Mono, Consolas, source-code-pro, monospace

I hope this helps.

Regards,
​Mutahhir


#3

Hello, thanks for reply :slight_smile:

Based on your reply, I did check it through. Then I realized, ‘Show Invisibles’, is the problems of this. Font seems fine, but whenever I chose the option ‘Show Invisibles’, then it is happening again :open_mouth: Very strange, it’s totally okay on PC.

Anyway I turned it off and now it’s very much okay. :smiley: thank you.

Sincerely,
Kesus