Disk shows more than used


I am using cloud9 for building node.js app with mongodb
I create custom ubuntu server, run mongodb and node js.
All is OK, But I cant understand one thing.
DISK usage is 3995 / 5120 MB, but when I check my workspace size with command du -hs workspace/ it shows me 236 MB. I think mongodb logs can fill DISK or grunt. Do you have any ideas ? Please help

Thank you


Probably related to lots of files in your workspace changing slightly from the normal workspace files and therefore counting against your quota. Read up on the long explanation of this and let me know if this is what’s going on:


Sorry, But I didnt use apt-get update. I just created workspace, clone git repo, and build with grunt, I check mongoDB logs, but these are very small to fill disk


Good to know. Can you have a look at how to clear up disk space? That should help you find out exactly what is taking up so much room.


Here is result when I run command du -m -d 1 -a | sort -n
1 ./README.md
2 ./.c9
14 ./grapheditor
221 ./graphEditorWebsite
236 .

then I run this command from root directory
0 ./.dockerenv
0 ./.dockerinit
0 ./dev
0 ./proc
0 ./sys
1 ./boot
1 ./build
1 ./lib64
1 ./lost+found
1 ./media
1 ./root
1 ./run
1 ./srv
8 ./bin
8 ./sbin
9 ./etc
32 ./lib
57 ./tmp
235 ./var
303 ./opt
411 ./mnt
1090 ./home
1261 ./nix
3154 ./data
5163 ./usr
11726 .


Can you also check the output from:

du-c9 | sort -h

and the output from the quota command?


Tool du-c9 outputs error "Invalid Flags:"

From running sudo du -sh /* in your workspace it seems the /data directory is what’s taking up all your space. It’s taking up 3.1GB.