Disable tooltips, uninstall sdk


#1

Hi, sorry if this isn’t the right place to post about this. I would like to disable the white-on-grey tooltips that appear when I move the cursor into function-call parens in js: for example, when I move inside a require() statement, a 2-line tooltip appears saying
require(id) – id: string
which I find visually disruptive. It would be even better if I could press F1 (or something) to get this info only when needed.

I installed the SDK on my local machine and edited
c9sdk / plugins / c9.ide.language / tooltip.js
line 52, changing ‘cursormove’ to ‘xcursormove’, just to disable it, which worked. Now I’m left with a few questions:

  1. Can I apply this to my projects on cloud9’s default interface on c9.io? Or will this only work in my SDK installation?

  2. Is it possible to run the SDK from cloud9.io? I tried, but I really don’t know what I’m doing yet! I went into one of my existing workspaces, cloned the git repo, ran the installation script, and executed server.js. It said
    server listening at http://172.17.47.52:8080
    but I wasn’t able to retrieve that url in my browser - I got ERR_CONNECTION_TIMED_OUT.

  3. What’s the clean way of uninstalling the SDK? When I installed it on my local machine, it created a /home/.c9 folder with a lot of stuff in it, as well as the c9sdk folder I installed it to.

  4. Is there a way to get that behavior where I press F1 to display the tooltip?

Thanks!


#2

I should add: the F1 behavior isn’t a big issue for me; disabling the tooltips is more imortant.

Also, the tooltip only pops up in some function-call parens. In the following example…

require(‘express-handlebars’).create(config)

…the tooltip appears inside the first set of parens but not in the second. Does anyone know why that is? (Although I’ve tinkered with tooltip.js, I’m a long way from fully understanding it.)

Thanks.