Difference width in display between tab and space



I use Go language on chromebook. But I have a problem with Cloud9 editor.
Please let me know if you have the solution.


Tab size setting is 4. But it looks like 7 in display.
I often edit wrong position.

Golang has code formatter and it use tab not space for indent.
So, I can not use space.

  • Tab image


Device : ASUS Chromebook flip C100PA and C200.


I tried the following setting.

Tab size

I changed tab size 4 -> 2.
It looks like 7 -> 3 spaces.

Display resolution

This problem occurs at display resolution 1200 x 800 and 1366 x 768.

But it does not occurs when the resolution is 1920 x 1080(Extended display).

Font Setting

I thought it might be caused by proportional font.

So, I set chromebook’s fixed font.

Code Editor Setting -> FontFamily

Noto Sans Mono CJK JP, Monaco, Menlo, Ubuntu Mono, Consolas, source-code-pro, monospace

But this setting has no effect.

Thank you.


This is an issue with fonts.
Could you try to turn off show invisibles setting.
Or try changing font family setting to just just monospace or Cousine


Thank you for your great solution!

My problem has been solved.

I tried the followings.

Preferences -> User Settings -> Code Editor (Ace) -> Show Invisible Characters : OFF

This solution is good.

Preferences -> User Settings -> Code Editor (Ace) -> Font Family : Cousine

Maybe Cousine is good.

  • Cousine is Good.
  • Cousine, monospace is Good.
  • monospace is not good.
  • monospace, Cousine is not good.

I can see invisible characters in this font setting solution,


I used Macbook pro 15 (1920 x 1200).
I came across this problem again.

The solution was only Invisible Characters in this case.

So, I think Invisiblle Characters setting is better than Font Family: Cousine.


try setting font-family to

Cousine , Monaco, Menlo, Ubuntu Mono, Consolas, source-code-pro, monospace

Cousine font is only present on chromeOS, so using it alone may break other platforms


My problem on Macbook Pro has been solved by the Font Family setting.

Thanks for your solution and font advice.