Debugging mode prevents runner from working

debug
php
wordpress

#1

So I use Runner: Apache httpd (PHP, HTML) and I have a Wordpress installed in there. Debugging is awesome - when it works. I can reproduce the problem easily.

  1. If I run the runner without the green bug (debug mode), it starts and works instantly.
  2. Then I stop it.
  3. I enable debug mode with green bug.
  4. I then try running it.
  5. Nothing happens, the preview says “No application seems to be running here!” even though it seems running in the IDE.

Usually it works, but when it doesn’t it’s often when I’d need it the most. I prefer to always run it in debug mode so I can add breakpoints any time. If I don’t want debugging then I don’t add breakpoints. But normally I’d have the bug on green all the time.


#2

are there any errors in the browser console


#3

Yes, never thought to open the console for the IDE, but here it is, it appears as soon as I try to start it.

The browser is latest Chrome.


#4

strange looks like runner is null.
Could you try closing the output tab, and opening a new one?


#5

Sorry but which one is the output tab? Now it works, but what happens if the problem comes back again, may I just update this thread?