Debugger trying to connect to port in use when launching Node cluster

nodejs

#1

I am trying to use the Node cluster module in my app. Workers are forked fine and then c9 is assigning debuggers to each worker process, but it always tries to assign a debugger at port 15455. However the vfs-worker process is always assigned at 15455 and I get an EADDRINUSE error. I have tried killing the vfs-worker process hoping that it would reconnect on another port, but no luck. It looks like the other processes continuefine, except none of them start listening and I cannot access my app through my c9 domain. I’m not sure why I can’t connect to my site if all the other processes are still running. I made a post here with my full bin/www on stackoverflow.

my post


#2

This might be related to an open issue with node - see https://github.com/nodejs/node/issues/4419

Could you link to your Stack Overflow question? Other people may benefit from the answers…


#3

I think it’s a cloud 9 bug with the debugger and or runner. I get the EADDRINUSE and can’t connect to the application when I run the application with a runner, but everything works fine if I just do

~ node ./bin/www

The debugger doesn’t try and connect and I get no errors. So I think the c9 debugger isn’t checking whether or not a port is available before trying to connect to it. It seems to start at the default debugger port and connect new debugger instances to higher port numbers as Node processes are forked and it always gets the address in use error on the same port, 15455.


#4

@moonrhino68, I was wondering… did you found a solution for the issue? I am experiencing the exact same behavior trying to use the cluster module in my node app.


#5

Idem , i would also be interested if anyone would have the answer…
Thanks
S.