Debugger for C code not working, rookie programmer


#1

Hello,
I’m taking my first programming class (CS50x through Harvard online) and having trouble getting the debugger to work for my C code. Every time I run it by clicking green arrow I get this:

That workspace was affected by some downloads that had to do with the course, so I created another for troubleshooting. Debugger runs fine in the new one, but breakpoints don’t work/ there is no functionality.

Could someone point me in the right direction? Having a debugger would be great as the assignments become more complex. Thanks!


#2

runner is set to shell command, click on that and change to the c debugger one.


#3

Thank you! I wasn’t aware of that option.
Next issue: In the workspace created by the class, there is no option for “C (simple)” as I see in the workspace I created myself directly through Cloud 9, so I tried running in C++ to see what would happen. The code executes, but debugger does not see the breakpoints. The same thing happens in the workspace where I can select Runner:“C(simple)”.

The tutorial I’m following shows a Runner called “C (GDB Debugging)”. Is there a way to add this one?


#4

Problem solved, for anyone else taking CS50 who may stumble across this post, running Update50 has added the GDB Debugging Runner back in again.