Custom runner file cannot be found

runner

#1

I just started using Cloud9 and I’m having an issue with the custom runners. Whenever I try to run a custom runner file, I just get the output:

bash: .c9/runners/My Runner.run: No such file or directory

The runner file is there. I’ve tried moving the location of the file, and nothing seems to help.

I was attempting to make a custom one for my project, but I’m seeing this with the default custom runner you get when choosing “New Runner” under “Run with” on the demo project.

I’ve looked around for possible solutions, but most seem to indicate changing the bash command - however, it seems in my case that it simply cannot find the runner file at all, which is quite odd.

Any help would be greatly appreciated.

Thanks.


#2

Hey @btoconnor,

Have you seen the C9 docs on custom runners yet here:

Also here’s a link to someone who solved their custom Java Runner issue:

If still not working after these and your project is open, may you share the workspace link?

:hand: :link:


#3

Hi @mikeumus,

Thanks for replying to me. I have looked at the custom runner docs, and was trying to initially implement something very similar to what you’ve pasted. Unfortunately, the issue is that it can’t find the runner file at all, regardless of what’s in the runner file.

I was able to reproduce my issue (at least, to the best of my ability) on the demo project that is included when you start a new account. Apologies - I’m still new to c9, so I believe this is the link to it? https://c9.io/btoconnor/demo-project

Here’s a screenshot of what I get when I right click on “My Runner.run” on the left and select “Run”: http://i.imgur.com/M9PlR67.png

Thanks again


#4

Hello,

I have the same problem. I try to run the file with shell command and it promts "No such file or directory. If I use C++ it promts another error. What is the difference between all the different runners?


#5

Hi.

I have a similar problem.

Yesterday My Runner.run stopped working. Also, it appears as CLOUD9 not allowing spaces in the filename because it prints this error (it brokens the filename as “My” and “Runner.run”):

Running /home/ubuntu/workspace/.c9/runners/My Runner.run
g++: error: /home/ubuntu/workspace/.c9/runners/My: No such file or directory
g++: error: Runner.run: No such file or directory
g++: error: Runner.run.o: No such file or directory
g++: fatal error: no input files
compilation terminated.

Process exited with code: 4

My Runner.run is:
{
“script”: [
“g++ *.cpp -o Main”,
"./Main"
],
“working_dir” : “$file_path”,
“info”: “Compiling all *.cpp and running Main”
}


#6

Did anyone ever get a solution to this issue? I’m having exactly the same problem - when I try to run a custom runner i get a ’ No such file or directory’ error. I tried removing spaces from the filename and still get the same issue.