Cursor is not on the right position


#21

Thanks for your help, however this did not fix my issue :frowning:


#22

This issue of over a year old. I find it odd that all these suggested solutions did not solve the issue. Also, if it is as simple as modifying a font on a stylesheet…why hasn’t this bug been fixed? I am no longer going to use this product or suggest it to my team due to lack of support and basic functionality. How do you expect developers to use an IDE where the cursor isn’t correct?!?


#23

I went through all of these steps, and some other recommendations not in this thread. Nothing worked…until I changed the “monospace” in the default font family to “Monospace”. Now it works fine. The Chrome OS has the M capitalized for that font and does not contain any of the other fonts in the default list. Perhaps the issue is related to just not having a recognized font in the list available to the browser.


#24

I’m having the same problem. I changed the font to the ones listed above. I reset all user preferences to default and the cursor is still not right. What else can I do? I can’t code effectively without knowing where the cursor is. I’m using Chromebook OS Version 60.0.3112.114 (Official Build) (64-bit). This was not a problem until last week. Haven’t used C9 since and I really like it so please offer a solution so I can work on my project again.


#25

Could you try setting font family to Monospace or Cousine, and let me know if one of them works.
Looks like default fonts installed on chromebooks have changed recently


#26

Hi, I got here, because I was having same issue, when I set font family to OpenDyslexic.

From this thread I understood that the issue is happening for me, because I don’t use monospace font.
By changing font from normal to monospace, everything works.
I assume, that Ace is making some calculations about cursor position, using single character width. Everything is ok, when monospace font is used, but things get fucked when we use normal font.

Can someone please point me to place in code of Ace editor that’s making some calculations with coursor position?
Or tell me if I can programaticaly change those things, so I can use non-monospace font? (monospace dyslexic font is shit… )


#27

I tried changing to either font but it still doesn’t work.


#28

@TheNextRoot try adding user strylesheet from How do I install a font and use it on my editor?

@przemekkot there is an old pull request to ace adding support for variable width fonts https://github.com/ajaxorg/ace/pull/1608/files but it had some open issues.


#29

I tried following the directions from the link but it still isn’t working.
I’m attaching a screenshot so you can see the code I used. Maybe I’m doing
something wrong but I’m just not getting it.


#30

I found the answer in a Chromebook Help Forum. I had to change the fixed
width font to “Monospace” under settings/appearance/customize fonts.
Hopefully, this will help other Chromebook users.


#31

This was baffling me for a few hours, I tried each and every solution in the above thread, however, nothing helped. I believe @TheNextRobot was close, but they were vague in their solution. What I think they meant to say (and what worked for me) was:

  1. Click your Chrome settings menu (three bars thing) in the top right
  2. Settings
  3. Advanced
  4. Customize fonts
  5. Click the drop-down menu for “fixed-width fonts” and select “Courier”. This is the first font I found that worked for me, and I like it’s aesthetic, so I stuck with it. Maybe another works, but Courier definitely works.

That’s it!