Cursor is not on the right position


#1

Hey,

i have a little problem. The cursor is not on the position where you are typing. On a empty document, he will start on the left like normal but the more you type he will move “away”. The distance between cursor and code is getting bigger and bigger. I visualized it:

(No experimental settings or generally changed anything. Even this is the demo-project. Chrome OS.)

A lot of thanks in advance for a solution :wink:


#2

The font in the screenshot looks wrong, cloud9 works only with monospace fonts.
What is the value of User Settings>Code Editor (Ace) > Font Family?


#3

After doing “Reset to Factory Settings” it’s the source-code-pro font.


#4

That’s wrong, there must be an error in reset settings.

Please set it to Monaco, Menlo, Ubuntu Mono, Consolas, source-code-pro, monospace


#5

Thank you @harutyun. That worked!

@bradydowling some error in the reset settings :wink:


#6

Logged this so we can fix it, thank you @codingmonkey :monkey: :wink:


#7

I think I’m having the same problem. When I type in the code in the code editor the cursor is very far away, making it quite difficult to know where I’m about to type or delete. But the font is already set to the one mentioned above


#8

You’ll also want to try this out in incognito mode or private mode where there are no extensions installed because browser extensions can often cause this behavior.


#9

I also am having the same issue. I checked font family and it’s as specified by @harutyun.
I also tried to used incognito mode as suggested by @bradydowling and it still didn’t work.

I’m using a chromebook which was never an issue.
This cursor issue has been for a while now, and has stopped me from using ur amazing product :frowning:

Cheers,
Simon


#10

@sayo9394 could you please post a screenshot of the editor with misaligned cursor, to help us understand why is it broken.
Thanks,
Harutyun


#11

@harutyun the problem seems to be limited to chromebook with Chrome OS version 48.0.2564.116 (64bit)
I tested on latest chrome on a windows7 machine and all went well.


#12

On my Windows PC it works fine, but on my Chromebook with Chrome OS 50 it still bugged the way OP shows.

Green is where it’s expected to be, Red is where it actually is.


Cursor out of place on chrome OS
#13
@charset "utf-8";

.ace_editor, .ace_editor *
{
    font-family: "Monaco", "Menlo", "Ubuntu Mono", "Droid Sans Mono", "Consolas", monospace !important;
    font-size: 12px !important;
    font-weight: 400 !important;
    letter-spacing: 0 !important;
}

This css rules for c9 stylesheet seems to be workaround


#14

Which of this rules fixed it? or are all of them required?


#15
.ace_editor, .ace_editor *
{
    font-family: "Monaco", "Menlo", "Ubuntu Mono", "Droid Sans Mono", "Consolas", monospace !important;
}

reduced it to just this and it still works, so I guess something is about font rendering


#16

Here is a screenshot of my cursor problem, I have tried the possible solutions in this thread and they are not working for me. I hope i can get help so i can use the great app on my Chromebook without any problems.


#17

Can you list off specific solutions that you’ve tried and then send a screenshot of your font settings?


#18

Where is the c9 stylesheet located?


#19

I’m having the same issue. What was your solution?


#20

If you go to the gear in the top-right corner or press ctrl + , (no idea why comma, but it’s comma…), you can open the preferences menu. then go down to Code Editor (Ace), then a bit further down to Font Family and Font size and copy and paste “Monaco, Menlo, Ubuntu Mono, Consolas, source-code-pro, monospace” into the Font Family box, it will correct the issue. I’m not sure what the “stylesheet” is, but that’s how I fixed it. Good luck!

On a separate note to cloud 9 developers…if you’re going to make changing this area an option, could you please fix this bug?? I’d really rather look at this in Arial…I tried changing it and it REALLY screwed up the cursor placement. Thanks…