CS50 IDE Problems with update50 and debug50 (bash: /home/ubuntu/.prompt50: No such file or directory)


#1

Ive been using cs50 ide for while now and today i got a message to to update it using update50, when i was done updating however I closed the terminal and tried to used the command debug50, and it said the command was not found which was odd as i used it the previous day. I tried to run update 50 as well but that also said command was not found. Please help !!


#2

Hi @rivindub, mind clicking CS50 IDE > Restart, and trying debug50 again, see if that’ll work? Thank you!


#3

Already did that, still doesnt work. I even deleted the workspace and created a new one.


#4

@rivindub what do you get when you run ~/.cs50/bin/update50?


#5

Yes it updated cs50 ide and now debug50 seems to work fine, thank you so much!


#6

hi, i just had the same problem. When i wanted to run update 50, it said command not found… could you tell me how i can deal with it?


#7

@wenf mind posting a screenshot of your workspace please? Thanks!


#8


#9

@wenf afraid this doesn’t seem like a CS50 workspace! Please follow the instructions at https://manual.cs50.net/ide/faqs#my-workspace-doesnt-look-like-davids-from-lecture-and-none-of-the-50-commands-work-what-should-i-do to create one!


#10

“2.From Cloud9 > Go To Your Dashboard click on ide50”… sorry… i can’t even find ide50…


#11

@wenf in your case it should be called “hhhh” not “ide50”.