CS50 Debug *Still* Not Available

workspace

#1

It appears that I have lost my debug powers in the CS50 IDE. I unchecked “less comfy.” I logged in & out. I restarted the IDE. I refreshed my browser (Chrome). I ran update50. I rebooted my MacBook. I did a rain dance. Still, nothing (i.e., no “Debug” button, no “Run” button, nada). A “Debug” panel is still available on the right, however, it does nothing but mock me. Any potential remedies?


#2

Hi
Debug and preview buttons have been removed by cs50.
To use debugger run debug50 command in the terminal.
You can ask more about it the reasoning behind this change on cs50 facebook or reddit pages.
also you can add the following snippet to your init script

p = services.layout.findParent({ name: "preview" });
p.childNodes.forEach(function(x){
    x.setAttribute("visible", true)
})

to bring the buttons back.


Debugger problem with CS50
#3

Hi, I’m using the cs50 ide and looking for the run button too. I just have a html page, what script file would I add your snippet to?


#4

the script file opened from cloud9>open your init script menu


#5

Awesome! Thank you. It worked.