Cryptocurrency SOIL start node - how to? Doesn't connect

go
firewall

#1

Hey!
Great system. This is my day 1. Exciting.

I would like to develop an app on top of a (ecology-oriented) cryptocurrency called SOIL.

For that, I need to start a local client. Below is the shortest possible way to install the testnet node.

Installation works fine.
But then, the client does not seem to connect.
Is there a firewall running perhaps?
I need ports open: listen:39340, rpc:39342

How to get it connected?

What I expect:

When I do the same thing on a VPS provider (digitalocean, scaleway) the gsoiltestnet client is not only starting, but it is connecting to the existing peers, and starts downloading the blockchain:

... (like below)
I1026 15:11:25.308992    8811 cmd.go:114] Starting Gsoil_MMF_TN/v1.4.1-430cc246/linux/go1.6.3
I1026 15:11:25.309212    8811 server.go:311] Starting Server
I1026 15:11:27.374131    8811 udp.go:212] Listening, enode://ed51b7725c81f250e50c56e48a97ef674fac1e34621550aff9c082b70f2d4839f4812ce2f70a8e97f2e1c41b9f7e97d9881a727352cd005a2cb962020867dda4@[::]:39340
I1026 15:11:27.374381    8811 backend.go:526] Server started
I1026 15:11:27.377556    8811 ipc.go:112] IPC service started (/home/soil/.soiltnet/gsoil.ipc)
I1026 15:11:27.379117    8811 server.go:552] Listening on [::]:39340
I1026 15:11:37.385221    8811 downloader.go:288] Block synchronisation started
I1026 15:11:42.870713    8811 blockchain.go:1251] imported 192 block(s) (0 queued 0 ignored) including 0 txs in 3.202772157s. #192 [44072586 / 97be3249]
I1026 15:11:44.052282    8811 blockchain.go:1251] imported 256 block(s) (0 queued 0 ignored) including 0 txs in 1.162076812s. #448 [28fb71f0 / 218070f0]
...
etc.

What I see instead, on c9

gsoiltestnet js ~/SOIL/testnetpeers.js
I1026 14:29:41.762457   10618 database.go:71] Alloted 16MB cache to /home/ubuntu/.soiltnet/chaindata
I1026 14:29:41.768846   10618 database.go:71] Alloted 16MB cache to /home/ubuntu/.soiltnet/dapp
I1026 14:29:41.772684   10618 backend.go:314] Protocol Versions: [63 62 61], Network Id: 42
I1026 14:29:41.772797   10618 backend.go:362] Blockchain DB Version: 3
I1026 14:29:41.773193   10618 blockchain.go:214] Last header: #0 [e138e6c4…] TD=1024
I1026 14:29:41.773272   10618 blockchain.go:215] Last block: #0 [e138e6c4…] TD=1024
I1026 14:29:41.773288   10618 blockchain.go:216] Fast block: #0 [e138e6c4…] TD=1024
I1026 14:29:41.779162   10618 cmd.go:114] Starting Gsoil_MMF_TN/v1.4.1-430cc246/linux/go1.6
I1026 14:29:41.779374   10618 server.go:311] Starting Server

And then it stops there.

Bad.

Please help.

Thanks a lot!
Andreas


Install

This is what I have done, on a c9-Python-workspace:

N.B.: I did not do a sudo apt-get -y upgrade, because c9 warned me about quota. (How big is our quota anyways, I am in the “free forever” plan?)

sudo apt-get update
sudo apt-get install -y curl git jq libgmp3-dev build-essential cpulimit wget

curl -O https://storage.googleapis.com/golang/go1.6.3.linux-amd64.tar.gz
sudo tar -C /usr/local -xzf go1.6.3.linux-amd64.tar.gz
rm go1.6.3.linux-amd64.tar.gz

mkdir -p ~/go/bin
echo "export GOPATH=\$HOME/go" >> ~/.bashrc
echo "export PATH=\$PATH:\$HOME/go/bin:/usr/local/go/bin" >> ~/.bashrc
source ~/.bashrc

mkdir -p ~/SOIL
cd ~/SOIL
git clone https://github.com/martymcfly2015/go-soil.git
cd ~/SOIL/go-soil/
git checkout Testnet
make

mv build/bin/gsoil build/bin/gsoiltestnet
ln -s ~/SOIL/go-soil/build/bin/gsoiltestnet ~/go/bin/

cd ~/SOIL/
wget -O testnetpeers.js https://raw.githubusercontent.com/drandreaskrueger/cryptomanuals/master/SOIL/testnetpeers.js

gsoiltestnet js ~/SOIL/testnetpeers.js

For more infos see: https://github.com/drandreaskrueger/cryptomanuals/blob/master/SOIL/gsoiltestnet.md


#2

is there anyone out there?


#3

hello C9 support, anyone reading this?


#4

The problem is likely that only ports 8080, 8081, and 8082 are open, to prevent things like using SMTP ports to spam, and create a bad reputation for c9. If you need ports 39340 and 39342, I’m not sure that will be possible. It is possible to install the Cloud9 SDK on your own server for development, if you want to use Cloud9 but feel it’s too restricting. As for your other question, there is a disk space limit of 2GB, which you can see by going to the statistics window at the top right.


#5

Ah now I see. Thanks for those explanations. Yes, that is very possibly the reason.

prevent things like using SMTP ports to spam

What about selectively blocking SMTP and other ‘dangerous’ ports then? i.e. blacklist instead of whitelist.

To start developing on top of any coin, the default way is to connect to a node software running the currency wallet on localhost. And all decentralized cryptocurrencies are communicating via P2P ports - that need to be open.

So C9 is not yet willing nor ready … to join the financial revolution that is … cryptocurrencies :wink:

What a pity. Other than that, I really love the C9 approach. Very cool and slick and versatile interface. But looks like I have to move on, and find another platform to try this on.

Thanks a lot, dannytech. All the best to you.
Andreas

“He who gives up freedom for safety deserves neither.” (Franklin) lol


#6

Sorry to hear that. I’m not sure Cloud9 would have been the solution for you anyway, given they have a policy about using your app in production (which might cover cryptocurrency). As for the SMTP question, I’m not sure, it was probably easier and I prefer it, especially since they’ve set up port forwarding already for those. I’m not super-sure, but it may have something to do with them not wanting to allow using port 80 and other ports that require sudo, and it may simply be a limitation of the Docker containers they use. I would personally like to know the answer to that, you make an interesting point…


#7

For now, it would be dev’ing, not (yet) production.

So let’s see if anyone answers.

Also, perhaps when I find the time, I can come up with some workaround. Would keep this thread posted then.

But I think the whole new world of cryptos is too important, to not provide some tech options for developing apps on top, here on C9.

Thanks for your answer. Have a good weekend.