Could not setup or start Go completion daemon. Please reload to try again

go
autocomplete

#1

I am hit with this error message now after installing golang via ppa (published package archive)
Could not setup or start Go completion daemon. Please reload to try again.

what i did to update golang

  • sudo add-apt-repository ppa:gophers/archive
  • sudo apt-get update
  • sudo apt-get install golang-1.8

sanity check

echo $GOPATH
/home/ubuntu/workspace

echo $GOROOT
/usr/lib/go-1.8/

go version
go version go1.8.1 linux/amd64

great!, now lets edit some .go

okay refresh page…
okay refresh page with cleared cache

sadface, after it did not work, i tried to move the go install to the c9 default location

  • sudo rm -rf /opt/go
  • sudo cp -R /usr/lib/go-1.8/* /opt/go

sanity check

echo $GOPATH
/opt/go

go version
go version go1.8.1 linux/amd64

still has the same error

troubleshooting

  • looked in .c9 folder for some kind of error log…
    • nothing…
  • switched code completion off in preferences > go support > enable go code completion
    • switched both on and off
    • reload (still errors on either position)
  • stuck

#2

Hi
Are you seeing this on c9.io hosted workspace or with sdk?
Are there any errors in browser console?
If it is c9.io workspace, could you share it with so that i could debug the issue?


#3

Any updates on this thread? I’m getting the same error and there is not too much out there on this error.


#4

Any development so far ? Still Go autocompletion is not supported in ssh workspace.