Configuring gulp serve under cloud9?


#1

Please excuse me if this has already been asked here, but my forum search is coming up empty.

I’m attempting to get gulp (serve) functioning in a cloud9 project generated from the vanilla-es6-jspm repo, but having issues getting gulp configured to run properly here.

I’m running from the default gulpfile.js task that looks like:

//use babel transpiler for ES6 files in node without needing --harmony nor a gulpfile.babel.js
require('babel/register');

// require all tasks
require('require-dir')('./gulp/tasks', {recurse: true});

require('gulp').task('default', ['serve']);

and when it runs, it appears that everything is properly started:

karlkras:~/workspace/vanilla-es6-jspm (master) $ gulp
[18:49:05] [INFOS] Setting process.env.ENV=dev
[18:49:05] ### Running in dev ###
[18:49:07] Using gulpfile ~/workspace/vanilla-es6-jspm/gulpfile.js
[18:49:07] Starting 'sass'...
[18:49:07] Starting 'watch'...
[18:49:08] Finished 'watch' after 898 ms
[18:49:09] Finished 'sass' after 1.84 s
[18:49:09] Starting 'serve'...
[18:49:09] [INFOS] call `gulp serve --env dev --port 9002` (for example) to launch on another port
[18:49:09] [INFOS] call `gulp serve --env dev --disable-watch` if you don't need it
[18:49:09] [INFOS] call `gulp serve --env dev --open false` if you don't want the browser to open
[18:49:09] Finished 'serve' after 77 ms
[18:49:09] Starting 'default'...
[18:49:09] Finished 'default' after 16 μs
[BS] Access URLs:
 -------------------------------------
       Local: http://localhost:9000
    External: http://172.17.0.112:9000
 -------------------------------------
          UI: http://localhost:3001
 UI External: http://172.17.0.112:3001
 -------------------------------------
[BS] Serving files from: .tmp
[BS] Serving files from: src
[BS] Serving files from: jspm_packages
[BS] Serving files from: ./
[BS] Watching files...

but when I go to preview there’s nothing detected. I’m pretty sure it has to do with the localhost/port references but not sure where/how to configure them from gulp use.

Could someone please provide some hints?

thanks,
Karl


#2

you need to use port 8080 8081 or 8082, not printing output after Server started and until requests are made is usually normal


#3

sorry, please refer to my latest update.


#4

in your latest update you still have 9000 and 3001 and you need 8080, 8081 or 8082


#5

Yeah, the author provided the ability to modify the first port setting but not the second. I’ll have to dig into his scripts to figure that out, but wouldn’t localhost need to be changed too?