Code Intelligence popup won't go away for SSH workspace


#1

We’ve been using a C9 SSH workspace for a few months now and it’s absolutely brilliant, never been this easy to work on the same project with multiple people!

Now recently we started getting the popup that the new Code Intelligence is available for our language (mostly PHP) so we followed the link to this page: https://github.com/c9/c9.ide.language.codeintel/blob/master/README.md

We followed the instructions perfectly (had backups and tried multiple times) but it doesn’t seem to work. We don’t get any errors or anything during the installation of codeintel but after reloading our C9 workspace the popup just shows up again.

Is there any additional configuration that has to be done?


SSH Workspace CodeIntel Autocomplete for PHP not working
#2

I’d also like to know more about codeintel installation on SSH workspaces. I actually had thought we had code completion already working (basic code completion is already occurring, although not to the scale of a larger non-browser-based IDE, in terms of full application-defined methods and classes). So, question is, is it already installed? Or does it offer better support than the code completion included in the c9 workspace installation process on an SSH workspace?

Thank you very much; I can make a new thread if you want, but I figured the answer to my question might also be the answer to the one Boebi has brought up.


#3

I have the same issue.


#4

Can you post in a screenshot of the popup just so I know exactly which one you’re referring to?


#5

And installation guide button leads here: https://github.com/c9/c9.ide.language.codeintel/blob/master/README.md

We went through the installation steps but the message keeps showing, I have no idea if something actually changed or not. The popup never goes away, even if we tick the “Don’t ask again” checkbox.


#6

+1

Tried several times, as above. No errors installing virtualenv or codeintel. Using Webfaction SSH workspace.