Cloud9 terminal error: 'can’t create socket'


#1

Hi,

after resizing my disk space my terminal is now saying: “can’t create socket”.

I restarted the workspace and changed the disk space back to the old value – but nothing helped and this happened almost 24h ago.

What can I do now?


"can't create socket" error: deleted /tmp* occasionally instead of /tmp/*
#2

Is the workspace “oanstein-app”? It looks like you’re resizing again now, once that’s done if you still get this error I’ll investigate.


#3

Yes. I reloaded the workspace after the resizing didn’t finish for about 30 minutes. It’s resizing again and it’s stuck like before.


#4

Now it’s working again; I don’t know why, but thanks! Problem solved.


#5

Ok your workspace is up and running again. It looks like the terminal socket errors were due to an issue with your /tmp directory, either it didn’t exist or the permissions were wrong. I’ve recreated it and set it’s permissions to 777 with the following commands:

sudo mkdir -p /tmp
sudo chmod 777 /tmp

And it works again now.


#6

Hi @timjrobinson I accidentally deleted and remade my /tmp/ without the chmod and have the same problem.

could you set 777 on my tmp folder please? (I only have one workspace, that’s the one)

Thanks.

Edit:

Nevermind, found the solution here


#7

I also deleted the /tmp folder (accidentally), but I have no Linux console since, and therefor can’t recreate it and recover.
Any suggestions how to recover?

Thanks!
Dror