Cloud9 python2 can´t find manage.py


#1

I tried recently yo recover an old project I worked on. I didnt used it since July and the virtual server was hibernated.

After waiting for it to load I tried to run the server, with the same configuration that worked last time and without changing anything, and it popped up this message: "python2: can’t open file ‘manage.py’: [Errno 2] No such file or directory ".

If I try manage.py runserver it appears to run but when I try to go to the web my browser says the website doesn´t existe.

Did something change recently in Cloud9?


#2

Have the same issue: while even IDE sees the module (file), but python can’t see files and can’t import them even next to the one I run


#3

hi, I found the solution.

Click the right button of your mouse on the manage.py and select “Run”

and change the command like the picture : http://i.imgur.com/ANkri8F.png

It worked!

Sorry, new user only can put one picture. :frowning:


#4

Does the absolute path to that file include any spaces?

Cloud9 recently changed the way it handles spaces in the path/filename, so that could be it.