Cloud9 is spinning like a top yet the Status page says everything is great



Cloud9 is spinning like a top yet the Status page says everything is great.
Any news?

Files/File Tree Won't Load

Also can’t login to w/my C9 login? Or open workspaces. Or even the homepage.


Also having the same issue, all sandboxes spinning…

Edit: sandboxes finally finished “loading” 10 minutes after this behavior. However, I’m unable to save anything… C9 support, this behavior is super disruptive especially for a monday morning =\


I’m also having similar issues, workspace wont load


Workspaces opening now. Must be magic. Thanks c9.


up and running again


I’ve seen other posts on this error and that it seems to just fix itself, but this is irritating as all heck. We had this happen on another project and if we cloned it, it fixed it and we just worked from that, but we just started using C9 a month ago as our team’s dev environment and if this is going to happen once every project, we might just need to move somewhere else.


Same here, network capture reports 503 on


Sorry about this. We had some networking issues with our web host and this combined with a bad release caused some workspaces to be inaccessible. We should have updated this thread earlier. We updated the status page a minute or two after you posted here. For future reference for everyone else you can see any current issues with the IDE at


I’m having this same issue. C9 seems to have lost track of the save status. The file tabbed icon continues to spin after loading a file. I’ll make changes save, continue on another tab come back to the tab and it will say “Contents of file have changed on disk, do you want to reload?” I’m never sure which file it’s going to “bring back”. I’ve tried restarting, closing all tabs, etc, but nothing seems to work. Any suggestions?


Hello there,

same error.

C9.IO Team could you help me?

Thank you.