Cloud9 equivalent for windiff or diffmerge?


#1

Hi. I have two directories. One is the way the application looked at the end of Chapter 2. The other is the way the application looked at the end of Chapter 3. I would like to find out: 1) What files are different. 2) I’d like to be able to drill down and see what changed in a particular file, and then pop back up.

I’ve been doing it with diff --recursive --brief -w dir1 dir2 | grep -v node_modules
Then doing a diff on each file one by one, from the command line.
But this is going to happen a lot. I’d prefer a GUI way.

Is there one?


#2

Download both directories to my local hard drive and use diffmerge?


#3

Hi there,

While we would like to add integrated GIT support, we currently do not have it. Your suggestion of downloading the files to your local disk and running a diffing application from there sounds good.

Regards,

Remy


#4

All right. That’s how I’ll handle it. Thanks.


#5

Actually, I got my dander up, and tried installing kompare.

sudo apt-get update sudo apt-get install kompare
$ kompare auction chapter3
kompare: cannot connect to X server

After that, I tried installing the xorg-xserver, and discovered there is one already installed that is up to date. I tried starting that service, and it complained that I was trying to change the ownership of some files in the /tmp directory. I could have sudo-ed service x11-common start but I got cold feet. What if I blew myself out of my own session?

Just recording it as info for the next person, and to give someone a chance to say “all you need to do is this one simple step.”

…Rick


#6

Hmm. Maybe it can’t be done because it’s a virtual environment. There are no actual device drivers.

rhedin:~/workspace cd /etc/X11 rhedin:/etc/X11 sudo X -configure

X.Org X Server 1.15.1
Release Date: 2014-04-13
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-76-generic x86_64 Ubuntu
Current Operating System: Linux rhedin-auction-4836865 4.9.17-c9 #1 SMP Thu Mar 23 01:38:54 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.17-c9 root=UUID=f5d73494-1cf2-4811-8e2d-67884d4bd6e7 ro console=ttyS0,38400n8 cgroup_enable=memory swapaccount=1 apparmor=1 security=apparmor quiet
Build Date: 12 February 2015 02:49:29PM
:
nouveau
vesa
fbdev
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
No devices to configure. Configuration failed.
(EE) Server terminated with error (2). Closing log file.
rhedin:/etc/X11 $


#7

you can try using cloud9-vnc Can Cloud9 handle C++ GUI windows.


#8

What about checking your code into GitHub for future work and then comparing different branches or commits?
Introducing GitHub Compare View


Simple File Compare feature
#9

I think that will do the job. Thanks, eharman!

(Is there some way to click “Answer” here?)